Name:Asgard 2.0
 
Version:2.18.0.23269
 
Publisher:Katana
 
The following prerequisites are required:
 
  • Windows Installer 4.5
  • .NET Framework 4.7.2
If these components are already installed, you can launch the application now. Otherwise, click the button below to install the prerequisites and run the application.
 
Preferred installation method (Windows 10) Legacy installation method (Windows 8.1 or older)
Install / Launch
Install
Launch
 
ClickOnce and .NET Framework Resources